Symptoms:
- CheckMark Payroll will not launch.
- “Unable to create /CheckMark directory (Permission’s error 13)” – Error Message
- “CheckMark Error: 1. Unable to open the database. SQLITE_CANTOPEN[14]: unable to open database file” – Error Message
- “Unable to create the application database. Make sure you have Read & Write permissions for your Hard Drive.” – Error Message
- “Unable to initialize the application database. Payroll is unable to run without the application database. Payroll will exit.” – Error Message
- “Unable to [various text]. SQLITE_READONLY[8]: attempt to write a readonly database” – Error Messages
- “Unable to [various text]. SQLITE_MISUSE[21]:” – Error Messages
Cause:
CheckMark Payroll requires a directory named “CheckMark” be created with Read & Write privileges on:
- Mac: Macintosh HD (may be renamed)
- Windows: C: (may be renamed, but must be drive letter ‘C’)
The Symptoms listed above are a result of invalid permissions on one of the following:
- Mac: Macintosh HD
- Windows: C:
- The “CheckMark” Directory
- Payroll Database Files
Solution:
Mac OS X:
1) Close CheckMark Payroll if open.
2) Launch Finder.
3) In the sidebar on the left, locate the Macintosh HD under “Devices”.
NOTE: Macintosh HD may have been renamed on your Mac. In this case you can identify it by the Hard Disk icon.
* If the Macintosh HD is not showing in your Finder’s sidebar:
3.1) In the Mac Menu, select “Finder”, then select “Preferences”.
3.2) Click on the “Sidebar” tab in Finder Preferences.
3.3) Under “Devices”, check the box next to “Hard disks”.
3.4) Close Finder Preferences.
4) Back in your Finder window, select Macintosh HD from the sidebar to open the Macintosh HD.
5) Look for a folder named “CheckMark”. If you already have a folder named “CheckMark” under your Macintosh HD, then you may skip to Step 8.
6) In the Mac Menu, select “File”, then select “New Folder”.
7) Rename the new folder to “CheckMark” (case sensitive).
8) Select the new “CheckMark” folder to highlight it.
9) In the Mac Menu, select “File”, then select “Get Info”.
10) In the bottom-right corner of the CheckMark Info window, click the Lock icon to unlock Sharing & Permissions.
11) There are three different Name / Privilege combinations. Adjust the privileges to the following settings:
Name / Privilege
——————–
user / Read & Write
admin / Read & Write
everyone / Read only
NOTE: The Names listed on your Mac may be slightly different, but the order from top to bottom will be the same.
12) Directly under “Sharing & Permissions”, click the “Advanced” icon with the Cog-Wheel icon, then select “Apply to
enclosed items…” if it is enabled. If “Apply to enclosed times…” is disabled, you may skip this Step.
13) Close the CheckMark Info window to save the changes.
14) Relaunch CheckMark Payroll. Permissions issues should be resolved.
Windows:
1) Close CheckMark Payroll if open.
2) Launch Windows Explorer (double-click on “My Computer” icon, or select “Computer” form the Start Menu).
3) Double-click on “Local Disk (C:)” to open the C: Drive.
4) Look for a folder named “CheckMark”. If you already have a folder named “CheckMark” under your C: Drive, then you may skip to Step 7.
5) Click on the “New Folder” toolbar item, or right-click in empty white-space and select “New”, then select “Folder” to create a new folder.
6) Rename the new folder to “CheckMark” (case sensitive).
7) Right-click the “CheckMark” folder and select “Properties” to open the CheckMark Properties window.
8) Click on the “General” tab at the top of the window.
9) Next to “Attributes” near the bottom of the window, un-check the box next to “Read-only (Only applies to files in folder)”. You may have to click one or two times before the checkbox is completely de-selected.
10) Click “OK” on the CheckMark Properties window to save the changes. Select the “Apply changes to this folder, subfolders and files” radio-button and then click “OK” on the pop-up window.
11) Relaunch CheckMark Payroll. Permissions issues should be resolved.
* If you continue to experience any of the listed “Symptoms” after following these procedures, please email the Payroll
Support Team for further assistance: